[PATCH] IA64: Drop the unnecessary test for cc-version 0304.

From: Robert P. J. Day <rpjday_at_crashcourse.ca>
Date: 2007-11-16 12:16:54
Since the current build structure rejects any version of gcc < 3.2,
there's no point in testing for an even older version.

Signed-off-by: Robert P. J. Day <rpjday@crashcourse.ca>

---

diff --git a/arch/ia64/Makefile b/arch/ia64/Makefile
index 34951aa..ff18c72 100644
--- a/arch/ia64/Makefile
+++ b/arch/ia64/Makefile
@@ -39,11 +39,6 @@ $(error Sorry, you need a newer version of the assember, one that is built from
 		ftp://ftp.hpl.hp.com/pub/linux-ia64/gas-030124.tar.gz)
 endif

-ifeq ($(call cc-version),0304)
-	cflags-$(CONFIG_ITANIUM)	+= -mtune=merced
-	cflags-$(CONFIG_MCKINLEY)	+= -mtune=mckinley
-endif
-
 KBUILD_CFLAGS += $(cflags-y)
 head-y := arch/ia64/kernel/head.o arch/ia64/kernel/init_task.o

========================================================================
Robert P. J. Day
Linux Consulting, Training and Annoying Kernel Pedantry
Waterloo, Ontario, CANADA

http://crashcourse.ca
========================================================================
-
To unsubscribe from this list: send the line "unsubscribe linux-ia64" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Received on Fri Nov 16 12:21:04 2007

This archive was generated by hypermail 2.1.8 : 2007-11-16 12:21:24 EST