Re: [KJ][PATCH 02/03]ROUND_UP|DOWN macro cleanup in arch/ia64,x86_64

From: Milind Arun Choudhary <>
Date: 2007-04-13 14:31:40
On 14:13 Thu 12 Apr     , Luck, Tony wrote:
> On Fri, Apr 13, 2007 at 02:01:40AM +0530, Milind Arun Choudhary wrote:
> > -	size = ROUNDUP(size, iovp_size);
> > +	size = ALIGN(size, iovp_size);
> Why is "ALIGN" better than "ROUNDUP"?  I can't see any point
> to this change.
Its a janitorial work. I'm trying to celanup 
all the corners where ROUNDUP/DOWN & likes are defined.
Kernel.h currently has macros like ALIGN roundup DIV_ROUND_UP.
in this patch series I've added ALIGN_DOWN & round_down
[waiting for comments on the same.]

So as ALIGN macro does the same work as ROUNDUP,
      is at a common place
      & is accessible to everyone
it should be used instead...i think

Milind Arun Choudhary
To unsubscribe from this list: send the line "unsubscribe linux-ia64" in
the body of a message to
More majordomo info at
Received on Fri Apr 13 14:30:09 2007

This archive was generated by hypermail 2.1.8 : 2007-04-13 14:30:37 EST