q-tools-0.3 with Montecito support available

From: Stephane Eranian <eranian_at_hpl.hp.com>
Date: 2006-06-01 06:25:17
Hello,

I have finally released version 0.3 of David's q-tools
monitoring tool for Linux/ia64.

New features:
	- support for Dual-Core Itanium 2 (Montecito) processor

This tool works only on Itanium 2 and follow-on processor. It does not
work on the first generation Itanium (Merced) processor.

Requirements:

	- you need libpfm-3.2-060512 or newer to compile. On Debian you
	  need to grab libpfm3 from unstable. Otherwise, you can get a
	  copy at:
			http://perfmon2.sf.net

	- to run on Montecito, you need Montecito support in the kernel.
	  The mainline kernel, 2.6.16 and higher, has the required support.
	  SLES10 is known to have support. As for RHEL4, I think you would
	  need U5 (to be verified). You can check whether you have support
	  by looking at /proc/perfmon and the PMU model line. If it does not
	  say Montecito, this will not work.

	- On non-Montecito, the tool works all kernel 2.6.5 or higher.

	- this version works also with perfmon v2.2 (aka new code base) for
	  all Itanium processors, including Montecito. As this point, v2.2
	  requires a kernel patch which you can get at the web site mentioned
	  above.

You can grab the latest version of q-tools at:
	ftp://ftp.hpl.hp.com/pub/linux-ia64/q-tools-0.3.tar.gz
	MD5SUM: 3f9e5230fe258c2baa288d9c70fc73b2

Enjoy,

-- 
-Stephane
-
To unsubscribe from this list: send the line "unsubscribe linux-ia64" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Received on Thu Jun 01 06:33:48 2006

This archive was generated by hypermail 2.1.8 : 2006-06-01 06:34:00 EST