update_mmu_cache vs. lazy_mmu_prot_update

From: Christoph Lameter <clameter_at_sgi.com>
Date: 2006-05-24 07:40:01
On Tue, 23 May 2006, Chen, Kenneth W wrote:

> > Except that, instead of agreeing it should be renamed, I say it should
> > be deleted entirely.  It seems to represent that ia64 has an empty
> > update_mmu_cache, and someone decided to add a new interface instead
> > of giving ia64 that work to do in its update_mmu_cache.
> My memory recollects that it was done just like what you suggested:
> overloading update_mmu_cache for ia64, but it was vetoed by several mm
> experts.  And as a result a new function was introduced.

lazy_mmu_prot_update is always called after update_mmu_cache except
when we change permissions (hugetlb_change_protection() and 

So if we conflate those two then arches may have to be updated to avoid 
flushing the mmu if we only modified protections.

I think update_mmu_cache() should be dropped in page_wrprotect_one() in 
order to be consistent scheme. And avoiding mmu flushes will increase the 
performance of page_wrprotect_one.. lazy_mmu_prot_update must be there 
since we are changing permissions.
To unsubscribe from this list: send the line "unsubscribe linux-ia64" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Received on Wed May 24 07:40:55 2006

This archive was generated by hypermail 2.1.8 : 2006-05-24 07:41:06 EST