Re: Synchronizing Bit operations V2

From: Christoph Lameter <>
Date: 2006-03-31 11:49:22
On Thu, 30 Mar 2006, David Mosberger-Tang wrote:

> I have to agree with Hans and I'd much prefer making the mode part of
> the operation's
> name and not a parameter.  Besides being The Right Thing, it saves a
> lot of typing.

IMHO It reduces the flexibility of the scheme and makes it not extendable. 
Leads to a large quantity of macros that are difficult to manage. 

Also some higher level functions may want to have the mode passed to them 
as parameters. See f.e. include/linux/buffer_head.h. Without the 
parameters you will have to maintain farms of definitions for all cases.

To unsubscribe from this list: send the line "unsubscribe linux-ia64" in
the body of a message to
More majordomo info at
Received on Fri Mar 31 11:50:06 2006

This archive was generated by hypermail 2.1.8 : 2006-03-31 11:50:22 EST