Re: [patch 2/3] Replace pci_find_device with pci_get_device

From: Bjorn Helgaas <bjorn.helgaas_at_hp.com>
Date: 2005-01-11 08:21:56
On Mon, 2005-01-10 at 13:09 -0800, Jesse Barnes wrote:
> On Monday, January 10, 2005 11:46 am, domen@coderock.org wrote:
> > -  while ((dev = pci_find_device(PCI_ANY_ID, PCI_ANY_ID, dev)) != NULL)
> > +  while ((dev = pci_get_device(PCI_ANY_ID, PCI_ANY_ID, dev)) != NULL)
> >     acpi_pci_irq_enable(dev);
> 
> Shouldn't this be for_each_pci_dev(dev) acpi_pci_irq_enable(dev); instead?  
> Bjorn?

They're equivalent, right?  Looks OK to me either way.  I guess
if you switch to for_each_pci_dev(), you could switch the one
in sba_iommu.c, too.

-
To unsubscribe from this list: send the line "unsubscribe linux-ia64" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Received on Mon Jan 10 16:32:38 2005

This archive was generated by hypermail 2.1.8 : 2005-08-02 09:20:34 EST