Re: [PATCH] cleanup swiotlb.c a bit

From: Matthew Wilcox <>
Date: 2005-01-07 06:47:33
On Thu, Jan 06, 2005 at 11:38:07AM -0800, David Mosberger wrote:
> For example, something like this:
> +	io_tlb_start = alloc_bootmem_low_pages(io_tlb_nslabs *
> +					       (1 << IO_TLB_SHIFT));
> I find more readable if it's formatted as:
> 	io_tlb_start = alloc_bootmem_low_pages(io_tlb_nslabs
> 					       * (1 << IO_TLB_SHIFT));

I find the former more readable.  It lets you know there's something
coming on the next line.

> Well, it probably should move outside of the ia64 tree anyhow.  The
> way x86_64 includes swiotlb.c at the moment is just absolutely gross.

kernel/swiotlb.c would make most sense, I guess?

"Next the statesmen will invent cheap lies, putting the blame upon 
the nation that is attacked, and every man will be glad of those
conscience-soothing falsities, and will diligently study them, and refuse
to examine any refutations of them; and thus he will by and by convince 
himself that the war is just, and will thank God for the better sleep 
he enjoys after this process of grotesque self-deception." -- Mark Twain
To unsubscribe from this list: send the line "unsubscribe linux-ia64" in
the body of a message to
More majordomo info at
Received on Thu Jan 6 14:54:17 2005

This archive was generated by hypermail 2.1.8 : 2005-08-02 09:20:34 EST