Re: ptrace problem in 2.6.9

From: Stephane Eranian <eranian_at_hpl.hp.com>
Date: 2004-10-25 18:04:43
>   Stephane> Hi Roland, I have some problems with the recent
>   Stephane> modifications to the Ptrace infrastructure in 2.6.9
>   Stephane> release. Basically I have the smiple test program attached
>   Stephane> to this E-mail and it hangs in 2.6.9 but not in
>   Stephane> 2.6.9-rc4. Somehow the first waitpid() does not return. It
>   Stephane> is not clear to me why.  Is there something Ineed to
>   Stephane> change in the call itself?  I am running all of this on a
>   Stephane> 2-way IA-64 machine with 2.6.9. I have not tried on x86.
> 
>   David> Shoot, I think I ran into the same problem yesterday when
>   David> running the GCC testsuite.  In my case, the problem seemed to
>   David> disappear (mostly) after downgrading "expect" from the
>   David> "unstable" to the "stable" version, but the symptoms where
>   David> exactly like in your case: waitpid() didn't return, so I
>   David> suspect it really was the kernel's fault.  I'll try Roland's
>   David> patch on Monday.
> 
> Then again, may be not: it appears that the bug only relates to
> PTRACE'd processes, which "expect" is unlikely to do.  Oh, well, would
> have been too easy.
> 
In any case, that fixed the problem for me.

-- 
-Stephane
-
To unsubscribe from this list: send the line "unsubscribe linux-ia64" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Received on Mon Oct 25 04:28:13 2004

This archive was generated by hypermail 2.1.8 : 2005-08-02 09:20:31 EST