Re: [PATCH] Introduce PCI <-> CPU address conversion [1/2]

From: Ivan Kokshaysky <ink_at_jurassic.park.msu.ru>
Date: 2004-10-15 20:34:41
On Fri, Oct 15, 2004 at 12:19:26AM -0700, Richard Henderson wrote:
> So you conclude from 50% of the ports implementing things in a 
> particular way that you should invent a totally new interface?
> Isn't the obvious solution to implement the existing interface
> for the ports that don't have it?

Definitely.
Besides, pci_bus_to_phys() name is quite misleading. Sounds like
invitation to use phys_to_virt() with the returned value...
pcibios_bus_to_resource as the inverse of pcibios_resource_to_bus
would be much cleaner.

Ivan.
-
To unsubscribe from this list: send the line "unsubscribe linux-ia64" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Received on Fri Oct 15 06:35:17 2004

This archive was generated by hypermail 2.1.8 : 2005-08-02 09:20:31 EST