Re: [PATCH] 2.6 SGI Altix I/O code reorganization

From: Matthew Wilcox <>
Date: 2004-10-06 05:15:32
On Tue, Oct 05, 2004 at 12:10:08PM -0700, Grant Grundler wrote:
> > > Maybe rename pci_root_ops to "acpi_pci_ops" would make that clearer.
> > 
> > No.  Don't rename it to anything ACPI specific.  It isn't.
> I understand raw_pci_ops is not ACPI specific.
> But pci_root_ops is only used by pci_acpi_scan_root().

Yes, but if we had other ways of discovering PCI root bridges on ia64,
we would use it there too.  It's exactly the same as the i386 code which
has 7 different ways to discover PCI root bridges.

"Next the statesmen will invent cheap lies, putting the blame upon 
the nation that is attacked, and every man will be glad of those
conscience-soothing falsities, and will diligently study them, and refuse
to examine any refutations of them; and thus he will by and by convince 
himself that the war is just, and will thank God for the better sleep 
he enjoys after this process of grotesque self-deception." -- Mark Twain
To unsubscribe from this list: send the line "unsubscribe linux-ia64" in
the body of a message to
More majordomo info at
Received on Tue Oct 5 15:15:49 2004

This archive was generated by hypermail 2.1.8 : 2005-08-02 09:20:31 EST