Re: [PATCH] 2.6 SGI Altix I/O code reorganization

From: Matthew Wilcox <>
Date: 2004-10-06 03:45:58
On Tue, Oct 05, 2004 at 09:22:01AM -0700, Grant Grundler wrote:
> pci_root_ops should be static. It's only intended for ACPI.

What I had intended when I wrote this code was that platforms that didn't
want to use the generic SAL code (and why not?  It doesn't seem like it
should be the hardest thing in the world to move your hacks into SAL)
was that people should override

  struct pci_raw_ops *raw_pci_ops = &pci_sal_ops;

by just assigning raw_pci_ops in their own code.  I haven't looked at
the SGI code yet, but this is how arch/i386/pci/direct.c (for example)

> Maybe rename pci_root_ops to "acpi_pci_ops" would make that clearer.

No.  Don't rename it to anything ACPI specific.  It isn't.  It's just an
alternative route to access configuration space when you don't even
have a PCI bus, let alone a device.

"Next the statesmen will invent cheap lies, putting the blame upon 
the nation that is attacked, and every man will be glad of those
conscience-soothing falsities, and will diligently study them, and refuse
to examine any refutations of them; and thus he will by and by convince 
himself that the war is just, and will thank God for the better sleep 
he enjoys after this process of grotesque self-deception." -- Mark Twain
To unsubscribe from this list: send the line "unsubscribe linux-ia64" in
the body of a message to
More majordomo info at
Received on Tue Oct 5 13:49:44 2004

This archive was generated by hypermail 2.1.8 : 2005-08-02 09:20:31 EST