Re: [PATCH] 2.6 SGI Altix I/O code reorganization

From: Grant Grundler <iod00d_at_hp.com>
Date: 2004-10-06 02:22:01
On Tue, Oct 05, 2004 at 08:43:44AM -0700, Jesse Barnes wrote:
... 
> >   arch/ia64/pci/pci.c
> 
> It looks like the only non-codingstyle change here is to make pci_root_ops 
> non-static (and btw, some of the CodingStyle fixups look wrong).  If it needs 
> to be non-static, it should be declared in a header file so we don't have to 
> extern it in sn_pci_fixup_bus.

pci_root_ops should be static. It's only intended for ACPI.
Maybe rename pci_root_ops to "acpi_pci_ops" would make that clearer.

If SN2 platform needs hacks, then define "sn2_acpi_pci_ops" someplace
in the SN2 specific source code. In this case, SN2 will also 
need to continue to NOT use pci_acpi_scan_root() and define it's
own discovery. When SN2 firmware can support pci_acpi_scan_root(),
then it would make sense to drop the SN2 specific PCI discovery and pci_ops.
And both can co-exist - SN2 code can check which version of firmware
is installed and invoke ia64 ACPI support if that is known to work.

If SN2 needs something defined in the ACPI spec but missing from ia64
ACPI support, add the missing bits to arch/ia64/pci/pci.c.
It just shouldn't interfere with current use.

hth,
grant
-
To unsubscribe from this list: send the line "unsubscribe linux-ia64" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Received on Tue Oct 5 12:26:53 2004

This archive was generated by hypermail 2.1.8 : 2005-08-02 09:20:31 EST