Re: [PATCH] bug w/ shared interrupts

From: Bjorn Helgaas <bjorn.helgaas_at_hp.com>
Date: 2004-04-28 00:38:35
On Monday 26 April 2004 3:12 pm, David Mosberger wrote:
> I do think that iosapic_enable_intr() is
> misnamed now that it actually leaves the interrupt _masked_.  What
> it's really doing now is that it asserts that the I/O SAPIC routine is
> programmed to a correct/working value.  It would be good to fix that
> when changing the corresponding code in drivers/acpi/pci_irq.c.  IIRC,
> Bjorn already has patches which touch on that file.  If so, could you
> do a rename at the same time, Bjorn?

Sure, I'll take a look at that.  I think the only interface between
acpi/pci_irq.c and the architecture code will be acpi_register_gsi(),
though, so renaming iosapic_enable_intr() should be independent
of those changes.

Bjorn
-
To unsubscribe from this list: send the line "unsubscribe linux-ia64" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Received on Tue Apr 27 10:39:05 2004

This archive was generated by hypermail 2.1.8 : 2005-08-02 09:20:25 EST