RE: [ACPI] [PATCH] 4 of 6 introduce acpi_global_irq_to_irq()

From: Nakajima, Jun <>
Date: 2004-03-10 11:00:19
I agree with David. And GSI is more consistent with the ACPI spec, and
you don't need to explain what it is.

>-----Original Message-----
>From: David Mosberger []
>Sent: Tuesday, March 09, 2004 3:45 PM
>To: Bjorn Helgaas
>Cc:;; Andi
>Kleen; Nakajima, Jun; Brown, Len
>Subject: Re: [ACPI] [PATCH] 4 of 6 introduce acpi_global_irq_to_irq()
>>>>>> On Tue, 9 Mar 2004 16:26:31 -0700, Bjorn Helgaas
><> said:
>  Bjorn> i386, x86_64, ia64, ACPI: Introduce acpi_global_irq_to_irq()
>  Bjorn> Rename acpi_irq_to_vector() to acpi_global_irq_to_irq().
>  Bjorn> This function takes an ACPI global IRQ (often called a
>  Bjorn> "global system interrupt", but "global_irq" seems to be
>  Bjorn> commonly used in Linux), and converts it to a Linux IRQ.
>  Bjorn> This removes IA64 and PCI_USE_VECTOR #ifdefs from ACPI.
>The ia64-specific changes have my blessing.
>However, I'd _much_ prefer "gsi" in lieu of "global_irq".  It's much
>easier to think of the former as a numbering-scheme separate from the
>Linux irq numbers.  Justs my 2 cents...
>	--david
To unsubscribe from this list: send the line "unsubscribe linux-ia64" in
the body of a message to
More majordomo info at
Received on Wed Mar 10 00:56:37 2004

This archive was generated by hypermail 2.1.8 : 2005-08-02 09:20:24 EST