RE: [ACPI] [PATCH] add acpi_interrupt_to_irq

From: Nakajima, Jun <jun.nakajima_at_intel.com>
Date: 2004-01-23 14:36:17
> What does "vector" mean?  
For MSI, vector means the (external) interrupt vector, i.e. the index in
the IDT for MSI on x86. So acpi_irq_to_vector() is correct in that case.
ACPI looks at IRQ or GSI (Global system interrupt) vector (yes, it's
confusing). SOMETHING should be irq or gsi, as David suggested.

Since MSI does not require IRQ (but external interrupt vector), the way
we did for x86 was to use the vector to unify IRQ and vector. So
request_irq() actually gets the interrupt vector number, instead of irq.
That's the reason I preferred acpi_irq_to_vector() in that code with MSI
configured.

Jun
> -----Original Message-----
> From: Bjorn Helgaas [mailto:bjorn.helgaas@hp.com]
> Sent: Thursday, January 22, 2004 8:38 AM
> To: Nakajima, Jun; acpi-devel@lists.sourceforge.net; linux-
> ia64@vger.kernel.org
> Cc: Brown, Len
> Subject: Re: [ACPI] [PATCH] add acpi_interrupt_to_irq
> 
> On Wednesday 21 January 2004 8:36 pm, Nakajima, Jun wrote:
> 
> > > 	(b) is "acpi_interrupt_to_irq" a better name than
> > > 	    "acpi_irq_to_vector"?
> >
> > I don't know what people imagine by "interrupt", but to me it
implies an
> > "event".
> 
> Are you saying that you think "acpi_irq_to_vector" is the right name?
> What does "vector" mean?  The return value of that function is in
> fact a Linux IRQ, and is passed to request_irq() and free_irq().  So
> I think the correct name is "acpi_SOMETHING_to_irq".  If you don't
> like "interrupt", you can propose something else.  I just think it's
> misleading for the name to contain "to_vector", when it's really
> doing "to_irq".
> 

-
To unsubscribe from this list: send the line "unsubscribe linux-ia64" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Received on Thu Jan 22 22:38:18 2004

This archive was generated by hypermail 2.1.8 : 2005-08-02 09:20:21 EST