RE: [ACPI] [PATCH] add acpi_interrupt_to_irq

From: David Mosberger <>
Date: 2004-01-23 06:08:01
>>>>> On Thu, 22 Jan 2004 12:41:10 -0500, "Brown, Len" <> said:

  Len> Bjorn,
  >> irq = acpi_irq_to_vector(irq);

  Len> Yeah, this name is totally bogus; and your comments are
  Len> absolutely right.  I thank you for taking the time to address
  Len> it.

  Len> When I first saw this I said to myself, "hmm, shouldn't it be
  Len> acpi_irq_to_irq()?", nah, that seems even more stupid!";-)

  Len> Looks like this is only used for the SCI listed in the FADT.
  Len> So maybe we should just call it something like
  Len> acpi_fadt_sci_to_irq()?

It would be good to come up with a consistent naming scheme.  I/we
tried to do that in the ia64/iosapic.c, but it might need some
updating/revising with recent changes (such as MSIs).  Perhaps "gsi"
is also a contender for the ACPI interrupts.

To unsubscribe from this list: send the line "unsubscribe linux-ia64" in
the body of a message to
More majordomo info at
Received on Thu Jan 22 14:14:19 2004

This archive was generated by hypermail 2.1.8 : 2005-08-02 09:20:21 EST