RE: [ACPI] [PATCH] add acpi_interrupt_to_irq

From: Brown, Len <>
Date: 2004-01-23 04:41:10

> irq = acpi_irq_to_vector(irq);

Yeah, this name is totally bogus; and your comments are absolutely
right.  I thank you for taking the time to address it.

When I first saw this I said to myself, "hmm, shouldn't it be
acpi_irq_to_irq()?", nah, that seems even more stupid!";-)

Looks like this is only used for the SCI listed in the FADT.  So maybe
we should just call it something like acpi_fadt_sci_to_irq()?


> -----Original Message-----
> From: Bjorn Helgaas [] 
> Sent: Thursday, January 22, 2004 11:38 AM
> To: Nakajima, Jun;; 
> Cc: Brown, Len
> Subject: Re: [ACPI] [PATCH] add acpi_interrupt_to_irq
> On Wednesday 21 January 2004 8:36 pm, Nakajima, Jun wrote:
> > > 	(b) is "acpi_interrupt_to_irq" a better name than
> > > 	    "acpi_irq_to_vector"?
> > 
> > I don't know what people imagine by "interrupt", but to me 
> it implies an
> > "event". 
> Are you saying that you think "acpi_irq_to_vector" is the right name?
> What does "vector" mean?  The return value of that function is in
> fact a Linux IRQ, and is passed to request_irq() and free_irq().  So
> I think the correct name is "acpi_SOMETHING_to_irq".  If you don't
> like "interrupt", you can propose something else.  I just think it's
> misleading for the name to contain "to_vector", when it's really
> doing "to_irq".
To unsubscribe from this list: send the line "unsubscribe linux-ia64" in
the body of a message to
More majordomo info at
Received on Thu Jan 22 12:42:15 2004

This archive was generated by hypermail 2.1.8 : 2005-08-02 09:20:21 EST