Re: [ACPI] [PATCH] add acpi_interrupt_to_irq

From: Bjorn Helgaas <bjorn.helgaas_at_hp.com>
Date: 2004-01-23 03:38:18
On Wednesday 21 January 2004 8:36 pm, Nakajima, Jun wrote:

> > 	(b) is "acpi_interrupt_to_irq" a better name than
> > 	    "acpi_irq_to_vector"?
> 
> I don't know what people imagine by "interrupt", but to me it implies an
> "event". 

Are you saying that you think "acpi_irq_to_vector" is the right name?
What does "vector" mean?  The return value of that function is in
fact a Linux IRQ, and is passed to request_irq() and free_irq().  So
I think the correct name is "acpi_SOMETHING_to_irq".  If you don't
like "interrupt", you can propose something else.  I just think it's
misleading for the name to contain "to_vector", when it's really
doing "to_irq".


-
To unsubscribe from this list: send the line "unsubscribe linux-ia64" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Received on Thu Jan 22 11:38:43 2004

This archive was generated by hypermail 2.1.8 : 2005-08-02 09:20:21 EST