RE: [ACPI] [PATCH] add acpi_interrupt_to_irq

From: Nakajima, Jun <>
Date: 2004-01-22 14:36:43
To be clear, the vector-based PCI interrupt support for MSI is in 2.6.1,
but the particular ACPI code in -mm was a bug fix that we added

> -----Original Message-----
> From: Bjorn Helgaas []
> Sent: Wednesday, January 21, 2004 2:54 PM
> To: Nakajima, Jun;; linux-
> Any feedback on these questions from my previous mail:
> 	(a) do you want the #ifdefs in ACPI (as in 2.6.1-mm5),
> 	    or in the platform-specific code (as in my patch)?

I would like to avoid #ifdefs even in -mm5.

> 	(b) is "acpi_interrupt_to_irq" a better name than
> 	    "acpi_irq_to_vector"?

I don't know what people imagine by "interrupt", but to me it implies an

If we have definitions of acpi_irq_to_vector(irq) for other
architectures (as you basically did), we can remove #ifdef CONFIG_IA64.
For x86, we can switch the definition using CONFIG_PCI_USE_VECTOR. 

> 	(c) is acpi_os_install_interrupt_handler() saving the
> 	    wrong value in acpi_irq_irq?

I think the original IA-64 code was wrong (so CONFIG_PCI_USE_VECTOR will
be wrong there, too).  The value of irq is covered to vector by
acpi_irq_to_vector(irq) in acpi_os_install_interrupt_handler(), then
this value is set to acpi_irq_irq. But
acpi_os_remove_interrupt_handler() is given acpi_irq_irq (i.e. vector),
then it again calls acpi_irq_to_vector() prior to calling


To unsubscribe from this list: send the line "unsubscribe linux-ia64" in
the body of a message to
More majordomo info at
Received on Wed Jan 21 22:39:57 2004

This archive was generated by hypermail 2.1.8 : 2005-08-02 09:20:21 EST