Re: [PATCH] New CMC/CPE polling

From: Alex Williamson <>
Date: 2003-08-02 00:20:17
David Mosberger wrote:
>   Alex> +# define SAL_CALL_SAFE(result,args...)
> How about calling this SAL_CALL_REENTRANT() or something like that?
> SAFE isn't particularly meaningful and it's backwards from the
> caller's point of view (where SAL_CALL() is the safe macro to use...).

   Perhaps SAL_CALL_DANGEROUS() ;^)  Yes, I agree, the name is misleading
from the caller perspective.  SAL_CALL_REENTRANT() is a much better
choice.  Let me know if you want an updated patch.  Thanks,


Alex Williamson                             HP Linux & Open Source Lab
To unsubscribe from this list: send the line "unsubscribe linux-ia64" in
the body of a message to
More majordomo info at
Received on Fri Aug 1 10:20:36 2003

This archive was generated by hypermail 2.1.8 : 2005-08-02 09:20:16 EST