Re: [Linux-ia64] Building IA-64 toolchain

From: Jim Wilson <wilson_at_tuliptree.org>
Date: 2003-05-09 03:24:04
On Thu, 2003-05-08 at 04:21, navin wrote:
> ../../gcc-3.2/gcc/config/ia64/fde-glibc.c:42:3: #error You need GLIBC 
> 2.2.4 or later on IA-64 Linux

The glibc copy you are using is too old.  This glibc will work with gcc
2.96 (sic), but it won't work with gcc 3.  There were related changes
made to glibc and gcc to enable unwind info to work correctly, which was
needed for C++ exception handling support.  Thus you can't use a new gcc
with an old glibc or vice versa.

David Mosberger mentioned testdrive.hp.com or something like that. 
Perhaps you could get an account there, and then get a newer copy of the
glibc header files from there.

Jim
Received on Thu May 08 13:23:45 2003

This archive was generated by hypermail 2.1.8 : 2005-08-02 09:20:14 EST