Re: [Linux-ia64] janitor patch for _PAGE_SIZE_*

From: David Mosberger <>
Date: 2003-05-07 05:34:49
>>>>> On Fri, 2 May 2003 15:45:09 +1000, Martin Pool <> said:

  Martin> I was looking at the ia64 port and noticed the _PAGE_SIZE*
  Martin> definitions are inconsistent with other uses of this term in
  Martin> the kernel.

  Martin> This patch just renames them to _PAGE_SHIFT.  It only touches ia64
  Martin> code.

I'm not going to apply this one for the following reason: those macros
actually are page-size _codes_ for the PTEs.  Yes, the codes happen to
be equal to the log2() of the page-size, but this isn't necessarily
so.  It's probably unlikely this will ever change, but unless it's
nailed down by the architecture somewhere (I don't think it is), I'd
like to leave that distinction.  Subtle as it may be.

Received on Tue May 06 12:36:24 2003

This archive was generated by hypermail 2.1.8 : 2005-08-02 09:20:14 EST