[Linux-ia64] Re: [Pcihpd-discuss] PCI hotplug broken on IA64

From: Greg KH <greg_at_kroah.com>
Date: 2002-10-31 18:40:21
On Wed, Oct 30, 2002 at 10:55:12PM -0800, Lee, Jung-Ik wrote:
> 
> Hotplug drivers in drivers/hotplug are for Intel architecture,
> and the above APIs are available as global for both i386 and ia64.

Right now they are, but I have seen drivers for other architectures, and
can not change the pci hotplug core to rely on a ia64 and i386 only
solution, sorry.  Hopefully those other drivers will be in the main tree
soon.

> Actually, acpi driver uses them for ACPI/PCI population before 
> pci_dev is built for the hierarchy.

Yes, but acpi is only on ia64 and i386 platforms right now.  And for 2.5
I got rid of that usage :)

thanks,

greg k-h
Received on Wed Oct 30 23:43:16 2002

This archive was generated by hypermail 2.1.8 : 2005-08-02 09:20:10 EST