Re: [Linux-ia64] PXE boot off HP zx6000

From: Jason P Holland <jholland_at_cs.selu.edu>
Date: 2002-10-31 04:11:02
alex,
  i reset the machine and it worked with my configuration!  weirdness!  i
think i will email the pxelinux author and ask him to make a note on his
website that pxelinux.0 does not work on ia4 architechture.  thanks again
for your quick response!

jason

> Jason,
> 
>    Here's a know configuration that works:
> 
>    Debian 3.0 server (ia32)
>      tftpd-hpa      0.28-2
>      dhcp           2.0pl5-11
> 
> /etc/inetd.conf:
> tftp dgram udp wait root /usr/sbin/in.tftpd in.tftpd -t 1
>  -s /tftpboot
> 
> /etc/dhcpd.conf
>         host zx6000 { 
>                 hardware ethernet xx:xx:xx:xx:xx:xx;
>                 fixed-address zx6000;
>                 filename "elilo.efi";
>         }
> 
> You'll need an elilo.conf or some permutation of AABBCCDD.conf,
> which is your IP in hex (just like pxelinux).  Is the kernel
> file elilo.conf points at stripped?  You may want to strip it
> and gzip it to see if that helps.  Look in the logs to see
> what it's transfered and which file it's getting an error on.
> Are you loading an initrd as well (what size)?  What firmware
> is on your zx6000 ('info fw' from efi)?  Thanks,
> 
> 	Alex
> --
> Alex Williamson                                  Linux Development Lab
> alex_williamson@hp.com                                 Hewlett Packard
> 970-898-9173                                          Fort Collins, CO
> 
Received on Wed Oct 30 09:11:20 2002

This archive was generated by hypermail 2.1.8 : 2005-08-02 09:20:10 EST