Re: [Linux-ia64] [PATCH] dynamic IRQ allocation

From: Bjorn Helgaas <bjorn_helgaas_at_hp.com>
Date: 2002-08-03 01:56:33
> The patch basically looks fine to me, except for some naming issues.
> We now have vectors, global vectors, global system interrupts (GSIs),
> irq numbers, and what not.  This is confusing and hard to maintain.
> We should settle on a consistent set of names (hopefully something
> consistent with Linux, ACPI spec, and PCI spec).  I tried to do this a
> while ago (see big comment at the beginning of iosapic.c), but the
> picture described there is incomplete for large machines and doesn't
> do a good job at integrating with ACPI lingo.  Anyone want to take a
> stab?

This has been bugging me for a long time, too.  If nobody beats
me to it, I'll post a proposal next week.  How do you want to
handle the merging -- we now have a couple patches that I did
earlier, Takayoshi's patch, and the proposed naming patch that
all touch iosapic.c?  If you send me your current iosapic.c, I
can work from that.
-- 
Bjorn Helgaas - bjorn_helgaas at hp.com
Linux Systems Operation R&D
Hewlett-Packard Company
Received on Fri Aug 02 08:56:41 2002

This archive was generated by hypermail 2.1.8 : 2005-08-02 09:20:09 EST