Re: Why does git-core 0.99.7 require python 2.4?

From: H. Peter Anvin <>
Date: 2005-09-20 07:00:25
Junio C Hamano wrote:
> Fredrik Kuivinen <> writes:
>>Not supporting one of the major Linux distributions isn't ideal
>>though, so maybe we should do something about this. I will have a look
>>at rewriting the code to not use subprocess.
> Thanks -- I personally feel that it would be best to just let FC
> catch up, solving this problem for us, while you spend your time
> on other things first.

The problem isn't FC, the problem is RHEL, generally used on machines 
for which an OS update it's huge deal.

> Peter, if you feel strongly about it I'd do removing
> the 'requires python >=2.4', but as Fredrik says the only thing
> that uses Python 2.4 is his recursive merge, and it is not
> something we use without the user explicitly asking for it.  We
> can consider it as the same status as send-email or archimport
> which cannot work without Perl modules necessary for their
> operation, so if you can install bypassing requires- check that
> would work equally well.

My suggestion would be to fork off the recursive merge into a separate 
binary package which can have the python >= 2.4 requirement (unless 
Fredrik just fixes it.)


To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to
More majordomo info at
Received on Tue Sep 20 07:01:19 2005

This archive was generated by hypermail 2.1.8 : 2005-09-20 07:01:22 EST