Re: [ANNOUNCE] qgit-0.9

From: Marco Costalba <>
Date: 2005-08-15 20:22:47
Martin Langhoff wrote:

>I figured out that it wanted qt3-mt, installed it, and fiddled with
>the SConfiguration file.  Still no dice, perhaps because I have a qt4
>build environment?

I have qt 3 3.3.4 installed and I never dared to hope qgit can compile
with qt4, being a so huge compatibility break.

Now I am sure of it ;-)

>I actually like it quite a bit. So, notes for the build instructions:
>under debian, you want  to
>  apt-get install qt3-dev-tools libqt3-mt-dev
>Make sure there's_no_ qt4 build environment, edit SConstruct and have
>the env.Append line look like:
>'-I/usr/include/qt3'] )

With this modification qgit compiles also on no Debian platform, so I
have applied it to my tree too. Thanks ;-)

>And then make it, saying:
>  QTDIR=/usr make

Peraphs it is possible to teach SConstruct to understand 
also this last line?
So Debian users don't need to tweak anything.



Start your day with Yahoo! - make it your home page 
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to
More majordomo info at
Received on Mon Aug 15 20:26:23 2005

This archive was generated by hypermail 2.1.8 : 2005-08-15 20:26:27 EST